Saturday, March 24, 2012

Cisco CCNA: IP Routing

Cisco CCNA: IP Routing



Unit 1. Configuring IP Addresses



In this course you'll learn to configure IP routing for your network. This includes configuring IP addresses, assigning hosts for Domain Name Servers, setting up routing tables, and configuring interior and exterior gateway protocols.
In this unit, you will examine the IOS commands to assign, map, and verify IP addresses.
You will also learn about the Domain Name Server (DNS) and how names and addresses are mapped to each other.

After completing this unit, you should be able to:
  • List important IOS commands used for IP address configuration

  • Recognize host names

  • Assign DNS servers

  • Verify IP addresses

  • Troubleshoot IP address problems


This unit provides information that is relevant to the following CCNA exam objectives:
  • Identify the functions performed by ICMP

  • Configure IP addresses

  • Verify IP addresses


Topic 1.1: IP Configuration Commands

*Addressing Data
As you learned in earlier courses, IP is a Network-layer protocol that is essential in the Internet suite of protocols. IP works in conjunction with TCP, which is a Transport-layer protocol. TCP is responsible for the segmenting of data, whereas IP is responsible for the addressing and delivery of data packets.
*Types of Commands
We will discuss IP addressing now. Although there are many commands for configuring IP addresses, they generally fall into three categories:
  • Address assignment

  • Address mapping

  • Address verification


Topic 1.2: Address Assignment

*Assigning an IP Address
After you know the IP address to assign to your router interface, you need to configure this address on your router. This command, which is executed at the interface submode of the global configuration mode, uses this format:
Router(config-if)#ip address ip-address subnet-mask
In the example shown, Router1 is assigned the class C address 205.20.108.1.
Router1(config-if)#ip address 205.20.108.1 255.255.255.0

*Choosing an Available Address
Assigning addresses should not interfere with other IP addresses. In the graphic, the S1 interface of Router 1 is 205.138.78.1, which makes the wire address for the segment between Router 1 and Router 2 205.138.78.0. Therefore, the S0 interface of Router 2 should have the address 205.138.78.2, which is the next available IP address for network 205.138.78.0.

*Format of IP Addresses
By default, IP addresses and masks are displayed in show commands in the dotted-decimal format. These addresses can also be displayed in bit-count (network prefix, or /n notation) and hexadecimal format.

*Changing Format
The format of the network mask — dotted-decimal, bit-count, or hexadecimal — can be set on a per-session basis. Here is the syntax for this command, which is executed in privileged EXEC mode:
Router#term ip netmask-format {bitcount|decimal|hexadecimal}
Router1#term ip netmask-format decimal

*Formatting a Specific Line
If you want to display the IP address in a specific format on a specific vty or console line, use the command ip netmask-format in the line submode of global configuration. The format for this command is:
Router(config-line)#ip netmask-format {bitcount|decimal|hexadecimal}
Router1(config-line)#ip netmask-format decimal

show ip interface Command
The show ip interface command is one command that displays IP address information for an interface. This command is used to check a variety of interface settings.
Router1>show ip interface
FastEthernet0/0 is up, line protocol is up
  Internet address is 192.174.1.27/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is disabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP Null turbo vector
  IP multicast fast switching is disabled
  IP multicast distributed fast switching is disabled
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect exclude is disabled
  BGP Policy Mapping is disabled
Router1>
Question 1

Question 2

Topic 1.3: Address Mapping

*Mapping a Host Name to an Address
The IOS creates an internal table of host names and corresponding IP addresses. This table is used in the Domain Name System, which is discussed later in this unit. Therefore, you need to map your router's address with a host name.
The host name is any name chosen by the administrator, and the address is the IP address for that host. This command has the following syntax:
Router(config)#ip host name [tcp-port-number] address1 [address2...address8]
The host name and at least one address are required, but a maximum of eight addresses and a TCP port number are optional. In the example shown, Router2 is mapped to the address 172.84.109.1.
Router1(config)#ip host Router2 172.84.109.1

*Host Name Options
Using more than one address allows the host name to point to more than one device.
The TCP port number is used to specify a particular TCP port. The default TCP port is port 23 (used for Telnet), but there are a large number of TCP ports that can be used. Port 21, for instance, is used for FTP.
Router1(config)#ip host Router2 21 172.84.109.1 172.84.110.1

*Domain Name System
When host names are used to identify individual network nodes, routers must be able to recognize the names and associate them with IP addresses. Mapping between host names and IP addresses is performed by the DNS (Domain Name System).

*Designating DNS Name Servers
Individual hosts can be designated as DNS servers. These servers reply to name queries and retrieve names and addresses for network clients. To designate a host as a DNS server, the ip name-server command is used. This command has this syntax:
Router(config)#ip name-server server-address1 [server-address2...server-address6]
Router1(config)#ip name-server 205.13.224.161

*Designating Multiple DNS Name Servers
Any number of hosts may be designated as DNS name servers, but only six hosts can be designated as DNS name servers with a single command.
Router1(config)#ip name-server 205.13.224.33 205.13.224.65 205.13.224.97 205.13.224.129 205.13.224.161 205.13.224.193

*Default Domain Name
By default, DNS is used to determine the domain name.
However, the ip domain-name command can be used to set the default domain name.
The syntax for this command is:
Router(config)#ip domain-name [name of default domain]
Router1(config)#ip domain-name pluto

*Enabling DNS by Default
To enable DNS by default, use the address 255.255.255.255, which is the IP address used for local broadcasts.
Router1(config)#ip name-server 255.255.255.255

*Disabling and Enabling DNS
DNS can be disabled with the command no ip domain-lookup.
DNS can be re-enabled with ip domain-lookup.
Router1(config)#no ip domain-lookup
Router1(config)#ip domain-lookup

*The show hosts Command
Host names are stored in cache along with their mapped addresses. The command show hosts displays this information. The syntax for this command is:
show hosts [host name]
Router1>show hosts pluto

*Output for show hosts
The command show hosts displays the host name (Host), information and status of the name (Flags), number of hours since the name was referred (Age), protocol used (Type), and the logical addresses mapped to the name (Address(es)).
Router1>show hosts
Default domain is not set
Name/address lookup uses domain service
Name servers are 255.255.255.255
Host                     Flags      Age Type   Address(es)
yahoo.com                (temp, OK)  1   IP    204.71.200.245
                                               204.71.200.243
Router1                  (perm, OK)  0   IP    208.178.103.62
Router2                  (perm, OK)  0   IP    208.178.103.225
docstar.net              (temp, EX)  5   IP    209.130.187.10
Router1>
Flag Terms
There are two terms in the Flags portion of the output of the show hosts command. The first term indicates whether the name was manually configured as static (permanent), or if the name came from DNS (temporary). The second term indicates whether the entry is current (OK), or the entry is expired (EX).
Router1>show hosts
Default domain is not set
Name/address lookup uses domain service
Name servers are 255.255.255.255
Host                     Flags      Age Type   Address(es)
yahoo.com                (temp, OK)  1   IP    204.71.200.245
                                               204.71.200.243
Router1                  (perm, OK)  0   IP    208.178.103.62
Router2                  (perm, OK)  0   IP    208.178.103.225
docstar.net              (temp, EX)  5   IP    209.130.187.10
Router1>
Question 3

Question 4

Question 5

Topic 1.4: Address Verification

*Invalid Addresses
It is important that IP addresses are configured correctly.
Most problems associated with IP networks are due to incorrect addresses.
Administrators assigning IP addresses should take great care to ensure that the addresses they assign are correctly configured.

*Verification Commands
Once administrators assign IP addresses, the addresses should be verified.
Three commands used for IP address verification are:
  • ping

  • trace

  • telnet


Topic 1.4.1: Using Ping and Extended Ping

*The ping Command
The ping command attempts to make a connection between the Network layer of the source and the Network layer of the destination using ICMP (Internet Control Message Protocol) packets.

*How ping Works
The ping command sends an ICMP echo packet to the destination. When the destination receives the packet, it echoes the packet back to the source.
The syntax of the ping command is:
ping address
Router1>ping 204.71.200.243

ping Output
The output of the ping command in user EXEC mode shows ICMP packet information along with characters, such as the (!) characters below, indicating the success of the command.
Router1>ping 204.71.200.243
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 204.71.200.243, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/72/84 ms
Router1>
ping Output Characters
There are other characters besides (!) used in ping output. Other possibilities for output characters are:
  • ! Successful receipt of an echo reply
  • . Timed out waiting for a reply
  • U Destination unreachable
  • C Congestion-experienced packet
  • I Ping interrupted
  • ? Packet type unknown
  • & Packet TTL exceeded

Router1>ping 204.71.200.243
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 204.71.200.243, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/72/84 ms
Router1>
*Using Extended ping
The extended ping command allows an administrator to specify any Internet header options that are supported.
The extended ping command must be entered at the privileged EXEC mode.
An address does not need to be specified on the command line for the extended ping command.
Router1#ping
*Extended ping Output
Upon executing extended ping, the router interface will prompt the user for a variety of input parameters. The input parameters (or default values) are then used to customize ping output.
Router1#ping
Protocol [ip]:
Target IP address: 204.71.200.243
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Source address or interface:
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 204.71.200.243, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/70/80 ms
Router1#
Question 6

Question 7

Question 8

Topic 1.4.2: Using Trace

*How trace Works
The trace command is used with IP packets, which contain a TTL (Time-To-Live) field. When a router on the path between the source and target destination has to keep a packet because it doesn't know where to send it, the TTL value is regularly decremented as the router holds it.

*Time Needed to Make the Connection
When the TTL equals zero, the router along the path notifies other routers on the path that the TTL values have been exceeded.
This process allows the source to calculate the time necessary to connect to each device along the route to the target

*The trace Command
The syntax for the trace command is as follows:
trace address
Each router along the path to the destination address responds with the time it took for the trace packet to reach it (in milliseconds) or one of the following: !H if the packet was received but not forwarded; P if the protocol could not be reached; N if the network could not be reached; U if the port could not be reached, and * if a timeout occurred.
Router1>trace 204.71.200.243

trace Output
The output of the trace command provides a sequential list of routers encountered along the path to the target. Also shown are the times each response took.
Router1>trace 204.71.200.243
Type escape sequence to abort.
Tracing the route to yahoo.com (204.71.200.243)
  1 205.171.54.153 20 msec 28 msec *
  2 chi-core-02.inet.qwest.net (205.171.20.37) 16 msec 20 msec 16 msec
  3 sfo-core-02.inet.qwest.net (205.171.5.43) 64 msec 64 msec 64 msec
  4 sfo-edge-03.inet.qwest.net (205.171.18.1) 64 msec 64 msec 84 msec
  5 pos11-0-0-155M.br1.SFO1.gblx.net (206.57.8.33) 64 msec 64 msec 64 msec
  6 pos2-1-155M.cr2.SFO1.gblx.net (206.132.110.141) 68 msec 64 msec 64 msec
  7 pos6-0-622M.cr1.SNV.gblx.net (208.48.118.1) 64 msec 68 msec 64 msec
  8 pos0-0-2488M.hr8.SNV.gblx.net (206.132.254.37) 64 msec 64 msec 64 msec
  9 bas1r-ge3-0-hr8.snv.yahoo.com (208.178.103.62) 64 msec 68 msec 68 msec
 10 yahoo.com (204.71.200.243) 68 msec 64 msec 64 msec
Router1>

Topic 1.4.3: Using Telnet

*Application Layer Connection
The telnet command creates a connection from the Application layer of one device to the Application layer of the target device.

Topic 1.5: Troubleshooting IP Addresses

*Steps for Troubleshooting
In addition to their verification functions, telnet, ping, and trace are used to troubleshoot IP addresses. The following steps are used to find faults with IP addresses:
  • Telnet to determine if an Application-layer-to-Application-layer connection can be established.

  • Ping to determine if a Network-layer-to-Network-layer connection can be established.

  • Trace to determine the last reachable router.


Question 9

Question 10

Question 11


* Exercise 1
Try designing a network and assigning IP addresses.


Examine the following table
Step Action
1 Draw a diagram of a network containing 16 routers with lines connecting all routers.
2 Label each router connection as an interface (e0, s0, s1, etc.).
3 Using the network address 204.78.208.0/20, design a subnet plan for your network.
4 Label all connections with the wire addresses from your plan.
5 Create routing tables for each router and assign IP addresses to each interface.
6 Make a list of commands needed to assign, map, and verify the IP addresses for your network.


Topic 1.6: Unit 1 Summary

In this unit, you learned how to configure IP addresses. You were introduced to various IOS commands and saw how these commands are used to assign, verify, and troubleshoot IP addresses. You also learned about DNS and how to map host names to IP addresses.
In the next unit, you'll analyze the ways to configure routing tables and related information.

Unit 2. Basic Routing Configurations



In this unit, you'll explore the basics of IP routing. You'll examine the commands for enabling and disabling IP routing. Then you'll study the types of routes that you can set up for your routing table: static, default, and dynamic routes.
Next, you'll look at the default administrative distances and learn how and why you may want to re-configure one of the defaults.
After that, you'll compare the protocols used in IP multicast routing.

After completing this unit, you should be able to:
  • Enable and disable IP routing

  • Identify types of routing

  • Change administrative distances

  • List IP multicasting protocols


This unit provides information that is relevant to the following CCNA exam objectives:
  • Prepare the initial configuration of your router and enable IP

  • Identify the functions of the TCP/IP network-layer protocol


Topic 2.1: Enabling IP Routing

*Enable IP Routing
Once your router interface is set up with an IP address, you have need to make sure IP routing is enabled before you can transmit data to remote devices on outside LAN or WAN networks. IP routing is enabled by default. The commands to re-enable and disable are shown here.
Router(config)#ip routing
Router(config)#no ip routing

Topic 2.2: Types of Routes

*Establish Routes
Now that you have enabled IP routing on your router, you need to establish routes for the IP routing table and configure gateway protocols.
To establish routes to outside networks, you must determine what kind of paths work best for your network. The categories consist of static routes, default routes, and dynamic routes.

Topic 2.2.1: Static Routes

*Static Routing
Static routes are one-path routes between a source and a destination. Static routes are configured manually by the network administrator. Like default and dynamic routes, they are entered into the IP routing table.

*Command for Static Routing
The command syntax for static routing is:
Router(config)#ip route address mask {address|interface} [distance]
[tag tag] [permanent]
The address is the destination network. In some documentation for this command syntax, the term prefix substitutes for the word address.
mask is the subnet mask; if it is omitted, the default mask is used. Either the address or the interface of the next-hop router is required. The distance is the administrative distance, which we will cover later in this unit. The optional tag matches values for redistribution in route maps, which also will be discussed later. If the permanent option is specified, the route remains in the IP routing table even if the interface is shut down.
Router(config)#ip route 192.168.3.123 255.255.255.0 192.168.1

*Increase Security
Static routing is used to increase network security in a small network.
Also, the network must not change often; otherwise the network administrator will have to continually update the static route.
*Send Unroutable Packets
Static routes are also used to send unroutable packets to a particular destination router.
This destination is called the gateway of last resort.

Question 12

Question 13

Topic 2.2.2: Default Routes

*Smart Router
Default routes define a path to a smart router. A smart router is one whose routing table contains information for an entire network or internetwork.
Generally, dynamic routing protocols like RIP and IGRP will use administrative distances and metrics to determine a default route without extra manual configuration.

*Configure a Default Manually
Sometimes, though, a router cannot forward a packet using its dynamic routing table information. In such cases it's a good idea to manually configure a default route to a smart router.

*Configuring a Default Route
This is the command syntax for configuring a default route:
Router(config)#ip default-network network-number
Multiple default routes can be configured. Even with multiple default routes, default routes generally decrease the size of routing tables.
In the example shown, packets lacking a routable destination address will be sent to network 110.320.0.0.
Router(config)#ip default-network 110.320.0.0

Topic 2.2.3: Dynamic Routes

*Dynamic Routing
By far, the most common routes are dynamically learned routes. These are what make routers so useful in internetworks. Dynamic routing protocols, such as RIP and IGRP, use metrics and administrative distances to determine the best path from a source to a destination.
This information is sent out in routing messages, which routers use to update their own routing tables.

*Determining Trustworthiness
Metrics, as you learned in an earlier course, incorporate such variables as bandwidth, hop count, load, and reliability into an algorithm that determine the best path.
Administrative distance is an arbitrarily determined rating of the trustworthiness of a source of routing information. The administrative distance can range from 0 to 255. A zero rating is the most trustworthy, and 255 is the least.

*Default Administrative Distances
The table on the next page lists default administrative distances. As you will see, a static route is considered very trustworthy, especially compared to an unknown source, or a dynamic protocol such as RIP.

*Administrative Distances
Examine the following table
Route Source Default Distance
Connected interface 0
Static route 1
Enhanced IGRP (Interior Gateway Routing Protocol) summary route 5
External BGP (Border Gateway Protocol) 20
Internal Enhanced IGRP 90
IGRP 100
OSPF (Open Shortest Path First) 110
IS-IS (Intermediate System-to-Intermediate System) 115
RIP (Routing Information Protocol) 120
Internal BGP 200
Unknown source 255


*Configuring Administrative Distance
You can configure an administrative distance with this command:
Router(config-router)#distance value [clns]
The value ranges from 0 to 255. The optional clns is for IS-IS when routes are derived from the CLNS (Connectionless Network Service) protocol.
Use this command to give preference to certain routes. In the example shown, the IGRP default administrative distance of 100 is re-configured to 80.
Router(config)#router igrp 20
Router(config-router)#distance 80

Question 14


* Exercise 1
Try enabling IP routing and configuring routes on a Cisco router.

Examine the following table
Step Action
1 Assume that IP routing has been disabled on your router. Write the command that enables IP routing. Use 192.168.1.27 as the IP address.
2 Set up a static route to connect from 192.168.1.27 to 192.168.2.0.
3 Enable RIP on your router.
4 Reconfigure the administrative distance for RIP to 75.


Topic 2.3: Multicasting

*Multiple Destinations
IP multicasting is a method for delivering high-bandwidth traffic to multiple destinations. Multicasting is the term for sending one packet to multiple destinations, instead of sending multiple packets to multiple destinations. In IP multicasting, the packet contains a group destination address.

To set up multicasting groups, the IGMP (Internet Group Management Protocol) is used. Multicast routers send IGMP queries to adjacent IP hosts on LAN networks. In response to a query, each IP host identifies their multicast groups to the multicast router. Next, the multicast router forwards a multicast packet to the networks that are members of the multicast group. IGMP uses Class D IP addresses.

*Multicast Protocols
Several routing protocols can be used to route to multicast groups:
  • DVMRP (Distance Vector Multicast Routing Protocol)

  • PIM (Protocol-Independent Multicast)

  • MOSPF (Multicast Open Shortest Path First)
We will briefly discuss each protocol.

*DVMRP
DVMRP (Distance Vector Multicast Routing Protocol) makes use of a flooding algorithm called reverse path forwarding (RPF). In RPF, a router floods a multicast packet to all attached interfaces except the interface that initiated the packet.
To determine the source interface, DVMRP requires a DVMRP unicast packet. If a destination interface does not want to receive the multicast, the router for the destination returns a "prune" message to stop the data to that network.

*Based on RIP
DVMRP is based on RIP, and consequently uses hop counts.
It is not considered to be network scalable, especially with networks that don't use prune messages.
It is used in MBONE. MBONE is the multicast backbone of the Internet. MBONE is a network within the Internet that transmits multicasts, which usually consist of video or audio data streams.

*PIM
PIM (Protocol-Independent Multicast) is another protocol that uses reverse path forwarding. It can be subdivided into PIM dense mode and PIM sparse mode.
In PIM dense mode, the PIM RPF can use a unicast packet based on any Internet protocol to determine the source interface. It is called dense mode because receiving interfaces tend to be densely populated, which causes more flooding.

*PIM Sparse Mode
PIM sparse mode works well when receiving LAN interfaces are more sparsely populated, even though they may transmit more data streams. PIM sparse mode functions with a first-hop router near the sending interface, a midway rendezvous point, and a last-hop router near the receiving interface.
The first-hop router sends data to the rendezvous point. Requests for packets are sent by the requesting interface's last-hop router to the rendezvous point, and only requested packets are sent on.

*MOSPF
MOSPF (Multicast Open Shortest Path First) is based on OSPF, and therefore works only on internetworks that use OSPF link states. The protocol, which needs a router in a network to know all possible links, works like a unicast routing protocol. It uses a shortest-path first algorithm for multicasting.
In MOSPF multicasting, a router uses MOSPF to determine the routes for each source/multicast group, and uses the same shortest route until it is notified of a change in network topology. MOSPF works best when there are relatively few sets of active or unstable source/multicast groups; otherwise, it requires substantial bandwidth. We'll discuss OSPF in the next unit.

Question 15

Question 16

Question 17

Question 18

Question 19


* Exercise 2
Try describing multicasting terms and protocols used in IP routing.

Examine the following table
Step Action
1 Define IP multicasting.
2 Describe IGMP.
3 List the types of routing protocols used in IP multicasting. Compare and contrast each protocol. Include the advantages, disadvantages, algorithms used, and method of operation for each protocol.


Topic 2.4: Unit 2 Summary

In this unit, you learned the basic commands for configuring IP on your router.
In addition to some practical IP commands, you examined the theory and protocols that make up IP multicasting.
In the next unit, you'll examine the core protocols for IP routing: the interior gateway protocols.

Unit 3. Interior Gateway Routing Protocols



You've already been introduced to interior routing protocols such as RIP and IGRP. However, before now, you didn't directly correlate these protocols with IP routing.
In this unit, you'll analyze the importance of interior routing protocols in IP routing, and take a closer look at the commonly used protocols RIP, IGRP, Enhanced IGRP, OSPF, and IS-IS.

After completing this unit, you should be able to:
  • Define an interior gateway protocol

  • Describe the distance vector protocols RIP, IGRP, and Enhanced IGRP

  • Describe the link-state protocols OSPF and IS-IS

  • List the commands to enable both distance vector and link-state protocols

  • Configure RIP and IGRP to run in the same autonomous system


This unit provides information that is relevant to the following CCNA exam objectives:
  • Identify the functions of the TCP/IP network-layer protocol

  • Add the RIP routing protocol to your configuration

  • Add the IGRP routing protocol to your configuration


*Interior Gateway Protocol (IGP)
When configuring routers, you need to choose the interior gateway protocol (IGP) that works best in your network. An interior gateway protocol is an Internet protocol that helps routers pass routing information within an autonomous system. Interior gateway protocols use metrics, such as bandwidth and hop count, to determine the best path for routing data.

*Several IGPs
There are several IGPs to choose from, including:
  • RIP (Routing Information Protocol)
  • IGRP (Interior Gateway Routing Protocol)
  • Enhanced IGRP
  • OSPF (Open Shortest Path First)
  • IS-IS (Intermediate System-to-Intermediate System)
We will describe each protocol. But first, we need to explain autonomous systems.

Topic 3.1: Autonomous Systems

*Autonomous System Features
An autonomous system is a network or group of networks that shares the following features:
  • The system is interconnected
  • The system shares the same administration
  • The system shares the same routing protocol

*Assigning Autonomous System Numbers
If the above conditions are met, then one 16-bit number can be assigned to the autonomous system. If the system is routing within itself, the network administrator can assign an autonomous system number. If the system uses an exterior gateway protocol such as BGP, then a unique number must be assigned by InterNic (Network Information Center).

Topic 3.2: RIP

*RIP: Small Networks
The first protocol you will examine is RIP (Routing Information Protocol), which is very commonly used, especially in smaller, more homogeneous networks. RIP exchanges routing information with UDP broadcast packets.

*Characteristics of RIP
RIP can be further differentiated from other routing protocols by the following characteristics:
  • It is a distance vector protocol, which means it relies on hop count to determine the best path through a network, and it uses split horizon to avoid rooting loops.
  • The maximum number of hops allowed is 15.
  • 30 seconds is the default time interval between for routing updates.
  • If no update from another router is received for 180 seconds or longer, RIP marks the router as unusable. If no update is received for 240 seconds or longer, RIP removes the other router's entry in its routing table.
  • Load balancing over multiple paths is supported.
  • Later RIP versions support CIDR (Classless Interdomain Routing). CIDR, or supernetting, is discussed in an earlier course.
Although we covered RIP and IGRP configuration in an earlier course, we will cover both again here.

*Configure RIP Globally
Configuration of RIP begins in global configuration. Use this command format:
Router(config)#router protocol
Router(config-router)#network number
With interior gateway protocols, the network specified in the second command is the network that will receive routing updates.
As you can see, we have configured RIP for our network, which has the number 20.0.0.0.
Router(config)#router rip
Router(config-router)#network 20.0.0.0

*Things to Know
Here are a few facts and rules that you should know about RIP configuration:
  • The network number cannot have any subnet numbers. However, the subnets in the specified network will be advertised.
  • To be included, each network must be specified; consequently, you may need multiple network commands.
  • Your router broadcasts information to all the interfaces included in the network specified.
  • You must specify this information for every router that is using RIP.

Router(config)#router rip
Router(config-router)#network 20.0.0.0
...
Router(config-router)#network 10.0.0.0

*Configuring the Default Network
If RIP is used on a router that has a configured default network path, as we discussed in the previous unit, RIP advertises it as a route linking to the non-existent network 0.0.0.0. Therefore, configuring the default network 0.0.0.0 is not necessary with RIP.

Question 20

Topic 3.3: IGRP

*IGRP: Larger Networks
IGRP (Interior Gateway Routing Protocol) was created after RIP and is especially tailored for larger, more complex networks that support varying values for bandwidth and delay.

*Characteristics of IGRP
Here are more characteristics of IGRP:
  • It is a distance vector protocol. It uses the flash update and poison reverse updates to expedite convergence, and split horizon to avoid routing loops.
  • The maximum number of hops is 255.
  • 90 seconds is the default time interval between for routing updates.
  • If no update from another router is received for 270 seconds (3 update periods) or longer, RIP marks the router as unusable. If no update is received for 630 seconds (7 update periods) or longer, IGRP removes the other router's entry in its routing table.
  • IGRP can accommodate unequal-cost load balancing multiple connections to a single network.
  • IGRP uses hops as well as bandwidth, MTU, Delay, level of reliability, and link load when determining the best path.
  • IGRP configuration must include the autonomous system number.
  • It supports CIDR.


*Two Commands for Configuring IGRP
These are the command formats for configuring IGRP:
Router(config)#router igrp autonomous-system
Router#(config-router)#network network-number
The network number is the IP address of a directly connected network. As with RIP configuring, this address cannot contain subnets, and you can execute multiple commands for multiple networks. IGRP sends updates to interfaces in whatever networks you have specified.
Router(config)#router igrp 112
Router(config-router)#network 192.168.0.0
Router(config-router)#network 116.22.5.0

*Commands for Each Network Number
The two networks shown here are now isolated and the autonomous systems 10 and 20 are associated with IGRP.
Router(config)#router igrp 10
Router(config-router)#network 192.168.0.0
Router(config)#router igrp 20
Router(config-router)#network 164.210.0.0

Topic 3.4: Running RIP and IGRP Together

*Configure IGRP and RIP to Run Together
As you learned in an earlier course, you can configure both IGRP and RIP to run concurrently on your router.

*Adjust the Administrative Distance
You can adjust the administrative distance if you do not want IGRP to displace RIP by default. By default, RIP's administrative value is 120, and IGRP's is 100.
In the example shown here, IGRP has been reconfigured to be less trustworthy than the administrative distance for RIP.
Router(config)#router igrp 20
Router(config-router)#distance 180

It is not necessarily advisable to run RIP and IGRP concurrently. This may cause routing loops, because RIP and IGRP have different update timers and send routing updates at different times.
If this happens, ICMP will step in with "TTL exceeded" messages because the TTL value will have reached zero.

Question 21

Question 22

Topic 3.5: Enhanced IGRP

*Enhanced IGRP: Improved Efficiency
Enhanced IGRP, as you can assume, is a derivative of IGRP. The main difference between the two is in convergence properties and efficiency.
Enhanced IGRP uses a high-performance algorithm called DUAL (Diffusing Update Algorithm) finite state machine to expedite convergence. DUAL tracks all routes advertised by all neighbors, and selects efficient, loop-free paths. The DUAL algorithm also increases Enhanced IGRP efficiency because it recalculates convergence only for those routers experiencing topology changes.

*Configuring Enhanced IGRP
This is the command format for configuring Enhanced IGRP:
Router(config)#router eigrp autonomous-system
Router(config-router)#network network-number
In the example, Enhanced IGRP is enabled on autonomous system 112. Enhanced IGRP will send updates to the interfaces in networks 192.168.0.0 and 116.22.5.0.
Router(config)#router eigrp 112
Router(config-router)#network 192.168.0.0
Router(config-router)#network 116.22.5.0

*Features of IGRP
Here are some additional features of Enhanced IGRP:
  • Enhanced IGRP has two tables: a neighbor table and a topology table. The neighbor table contains the neighbor's address and interface. The topology table contains all destinations that are advertised by neighboring routers.

  • It can operate with the Network-layer protocols IP, AppleTalk, and Novell Internetwork Packet Exchange (IPX). IP Enhanced IGRP can be used for variable-length subnet masks (VLSMs). IPX Novell Enhanced IGRP can be used for incremental Service Advertisement Protocol (SAP) updates. Also, IPX Novell Enhanced IGRP bypasses RIP's 15-hop count limit. AppleTalk Enhanced IGRP can be used for partial, bounded routing and load sharing.

  • It supports CIDR.


Question 23

Question 24

Topic 3.6: OSPF

*OSPF: A Link-State Protocol
OSPF (Open Shortest Path First) differs from the routing protocols previously mentioned in this unit because it is a link-state protocol, not a distance vector protocol.
OSPF was derived from the protocol IS-IS to function specifically in IP networks. We will discuss IS-IS in the next section.
OSPF uses LSAs (Link State Advertisements)  to maintain a consistent view of network topology.

*ABRs: Routing with Multiple Interfaces
OSPF subdivides network domains into areas, each of which is connected to one backbone area. An OSPF router advertises the state of its interfaces and the interfaces of neighbor routers.
OSPF routers are called ASBRs (Autonomous System Boundary Routers), or ABRs (Area Border Routers). ABRs are routers with multiple interfaces that can participate in multiple OSPF areas. ABRs maintain separate topological databases for each area where they belong.

*Characteristics of OSPF
OSPF can be further described as follows:
  • OSPF supports subnetting, virtual links, and stub areas. Stub areas do not receive information on routes outside of the autonomous system. Because of this, stub areas use a default external route, provided by the ABR, to outside destinations.

  • It supports CIDR.

  • Configuration options include bandwidth, retransmission intervals, interface transmit delays, router priority, interface output cost, and router hello- and dead-intervals. A hello-interval is the time interval, in seconds, at which the IOS sends hello packets on an interface. A dead-interval is the time, in seconds, that a router does not detect a hello packet; after this time passes, the router responsible for sending the hello packets is declared down.


*Configuring OSPF
The syntax for enabling OSPF is this:
Router(config)#router ospf process-id
Router(config-router)#network address wildcard-mask area area-id
The process id is a positive integer, which is locally assigned, unique to the internal local area, that identifies the OSPF routing process. In the second line, address is the IP address. The wildcard-mask is used with the address to define one or more interfaces to be associated with a specified area. The area-id specifies the area corresponding to the OSPF address, and can be entered as a decimal value or as an IP address; the area-id can also be a subnet address.
In the example shown, the Ethernet interface has eight bits reserved for the host address, and the serial interface has two bits. OSPF is configured on the network 131.107.0.0, which is directly connected to the router. The last line of code enables OSPF on all other networks.
Router(config)#interface ethernet 0
Router(config-if)#ip address 131.107.1.1 255.255.255.0
Router(config)#interface serial 0
Router(config-if)#ip address 131.107.254.1 255.255.255.252
Router(config)#router ospf 107
Router(config-router)#network 131.107.0.0 0.0.255.255 area 0.0.0.0
Router(config-router)#network 0.0.0.0  255.255.255.255 area 0

Question 25

Question 26

Topic 3.7: IS-IS

*IS-IS: More Efficient
IS-IS (Intermediate System-to-Intermediate System) is a link-state hierarchical routing protocol. It also known as OSI Integrated IS-IS.
In IS-IS, routers exchange routing information based on one metric, which is used to establish network topology. Because of this, IS-IS is more efficient. Also, IS-IS can route multiple Network-layer protocols because it uses packet fields not used in other routing protocols. Like the other interior gateway protocols previously described, IS-IS supports CIDR.

*Enabling IS-IS
Enabling IS-IS differs from the preceding protocols. These are the differences:
  • After you enable IS-IS, you assign it to interfaces instead of networks

  • Only one IS-IS process is allowed on a router

  • The area address for the IS-IS area and the router's system ID are defined by network entity titles (NETs).


*Syntax for Enabling IS-IS
This is the syntax for enabling IS-IS:
Router(config)#router isis
Router(config-router)#net network-entity-title
Router(config)#interface type number
Router(config-if)#ip router isis [tag]
In the first line, you enable IS-IS. In the second line, you specify the routing process NETs. The network-entity-title is the IP address. The third line specifies the interface (instead of the network) for IS-IS, and the last line specifies that the interface actively routes using IS-IS.
Router(config)#router isis
Router(config-router)#net 38.0001.0000.0000.000a.00
Router(config)#interface ethernet 0
Router(config-if)# ip router isis
Router(config#interface serial 0
Router(config-if)# ip router isis

Question 27


* Exercise 1
Try identifying the interior gateway protocols supported by Cisco routers.

Examine the following table
Step Action
1 List the distance vector protocols. Compare and contrast these protocols.
2 Write the commands to enable each protocol.
3 List the link-state protocols. Compare and contrast these protocols.
4 Write the commands to enable each protocol.
5 Perform a Web search for more information to add to your lists.
6 Use your findings to determine what interior gateway protocols would work best for your router.


Topic 3.8: Unit 3 Summary

One of the integral parts of IP routing is enabling interior gateway protocols for your routers. In this unit, you discovered the variety of these protocols from which you can choose: the distance vector protocols RIP, IGRP, and Enhanced IGRP; and the link-state protocols OSPF and IS-IS.
You discovered that the theory behind the protocols makes a difference in which one you choose. You also examined the commands to enable the protocol — or protocols — of your choice.

Unit 4. Exterior Gateway Routing Protocols



As you learn more and more about routing in internetworks, the protocol BGP keeps appearing. BGP is the protocol used as an exterior gateway protocol.
In this unit, you'll examine how exterior gateway protocols function. You'll concentrate on the details of BGP, the protocol that is widely used today. You'll also learn how to enable BGP and configure the aggregate routes used in CIDR.

After completing this unit, you should be able to:
  • Define exterior gateway protocols

  • Describe EGP

  • Describe BGP

  • Configure simple BGP commands


This unit does not address any specific Cisco objectives. However, it does provide background information that is essential for the CCNA exam.
In the course index, questions about background information are indicated with the abbreviation BCK and a short description of the question subject matter.

Topic 4.1: Intro to Exterior Gateway Protocols

*From One System to Another
An exterior gateway protocol is a routing protocol that is used to pass routing information from one autonomous system to another. Exterior gateway protocols need the following information:
  • The autonomous system number of the local router
  • A list of directly reachable networks that the exterior gateway protocol can advertise
  • A list of neighboring routers or access servers with which the exterior gateway protocol can exchange information


*Facilitating the Flow of Information
Exterior gateway protocols facilitate the flow of information between autonomous systems in an internetwork: for example, exterior gateway protocols can decrease routing loops and increase convergence.
They also isolate and protect one autonomous system, managed by one administration, from another autonomous system, managed by a totally different administration. This isolation can protect one autonomous system from another misconfigured or error-prone system.

*EGP and BGP
In this unit we will discuss these two exterior gateway protocols:
  • EGP (Exterior Gateway Protocol)

  • BGP (Border Gateway Protocol)


Question 28

Question 29

Topic 4.2: Exterior Gateway Protocol

*EGP: An Older Protocol
EGP (Exterior Gateway Protocol) is the older of the two exterior gateway protocols. It is an Internet protocol and is defined in RFC 904.
EGP is considered out-of-date. It has been replaced by BGP, which we will discuss next in much greater detail.

Topic 4.3: Border Gateway Protocol

*BGP: Replacing EGP
BGP (Border Gateway Protocol) exchanges routing reachability information with other BGP autonomous systems. It provides loop-free routing between autonomous systems.
As defined in RFC 1163, the BGP routing table is the first information exchanged after two autonomous systems set up a connection using a Transport-layer protocol. Updates are sent only if routing table information changes; consequently, a BGP "speaker" retains the most current version of the BGP tables for all routers involved during the particular connection. Keepalive messages are sent at specified time intervals to check that the connection is still live. Notification messages are sent if errors or unusual circumstances are detected.

*Configuring BGP
To configure BGP, follow this command syntax:
Router(config)#router bgp autonomous-system
Router(config-router)#network network-number [mask network-mask]
Router(config)#router bgp 120
Router(config-router)#network 142.227.0.0

autonomous-system and network-number
In the first command, autonomous-system is the number that identifies a router to other BGP routers. This command also enables the tagging of routing information as it is passed along the connection.
In the second command, network-number indicates the network that will be advertised. Note that this is different than the similar command for interior gateway protocols: for interior gateway protocols, the specified network is the one that receives routing updates, and for exterior gateway protocols, the specified network is the one that will be advertised. The optional network-mask is the network or subnet mask.

We will only introduce a few BGP commands now. BGP configuration can become very complex, and it is beyond the scope of this course.

*An Example of BGP Configuration
In the example shown here, network 142.227.0.0 will be advertised in BGP updates.
Router(config)#router bgp 120
Router(config-router)#network 142.227.0.0

There are actually two types of BGP: internal BGP (IBGP) and external BGP (EBGP).
IBGP is used on routers within a single autonomous system. EBGP is used on routers in two or more autonomous systems.
The commands for enabling are the same; in fact, almost all configuration commands are the same for both EBGP and IBGP. When discussing BGP in this unit, we are referring just to EBGP.

Topic 4.3.1: Synchronization

*Synchronization
BGP and IGP both work to pass information in and through autonomous systems. Therefore, BGP needs to synchronize with IGPs. Synchronization means that BGP advertises routes after the IGP has sent routing information through its autonomous system.
With synchronization, the BGP routes are known to the IGP, and therefore the IGP can proceed to route information as needed.

*Enabling and Disabling Synchronization
Synchronization is enabled by default. It can be disabled if your autonomous system is not routing traffic from another autonomous system, or if all the routers in your autonomous system are using BGP.
These are the commands to disable and enable configuration:
Router(config-router)#no synchronization
...
Router(config-router)#synchronization

*Resetting the BGP Session
After changing this or other BGP configurations, you need to reset the BGP session with this command:
Router#clear ip bgp {*|address|peer-group name} [soft [in|out]]
The * resets all current BGP sessions, the address resets only the specified BGP neighbor, peer-group name resets a specified BGP peer group, the soft option indicates whether routing updates are sent without resetting either inbound (in) or outbound (out) BGP sessions.
Router#clear ip bgp *

Topic 4.3.2: BGPv4

*CIDR: Supernetting
In an earlier course, you learned about supernetting, or classless interdomain routing (CIDR). CIDR reduces routing tables by route aggregation.
CIDR can do this because it separates an internetwork into domains. BGP Version 4 must be used for CIDR.

*Creating an Aggregate Entry
This is the command syntax to create an aggregate entry in a BGP routing table:
Router(config-router)#aggregate-address address mask [as-set] [summary-only] [suppress-map map-name] [advertise-map map-name] [attribute-map map-name]
The address is the aggregate address, the mask is the aggregate mask, the [as-set] option creates path information for the autonomous system, [summary-only] filters more specific routes from the routing updates, [suppress-map map-name] suppresses routes on the specified route map, [advertise-map map-name] , [attribute-map map-name] specifies the route map used.
Router(config)#router bgp 100
Router(config-router)#aggregate-address 133.0.0.0 255.0.0.0 summary-only

Question 30


* Exercise 1
Try describing and configuring BGP as your exterior gateway protocol for routing between autonomous systems.

Examine the following table
Step Action
1 Describe BGP. As part of your description, explain the differences between the following:
BGP and the interior gateway protocols such as RIP and OSPF
IBGP and EBGP
BGP (Version 3 and earlier) and BGP Version 4.
2 List the commands to do the following:
Enable BGP
Enable synchronization
Specify aggregate routing for CIDR.


Topic 4.4: Unit 4 Summary

In this unit you examined exterior gateway protocols, which can be compared to interior gateway protocols. You studied the BGP protocol, and learned how it is used to connect autonomous systems in IP internetworking.
The information presented in this unit enabled you to more thoroughly understand interior gateway protocols, which you also studied in this course. As a way to introduce you to these IP gateway routing protocols, you began this course by discovering how to configure IP addresses and set up IP routing for your router.

No comments:

Post a Comment